
Requirements 

 
The following are required to install and run the Data Assistant application: 
 

• IBM Compatible PC computer 
• Microsoft Windows XP with Service pack 1, or Microsoft Windows Vista 
• .NET Framework 2.0 
• Archive extraction tool such as WinZip or Microsoft Windows. 

 

Installation 
 
Your Data Assistant application is shipped as a zip file, ready for deployment into 
your local environment. 
 
To install the Data Assistant application: 
 

1. Open the DataAssistant.zip file using Winzip, Windows, or a zip-
compatible archive extraction tool of your choice.  

2. Extract the DataAssistant.exe file to your preferred location. 
• NOTE: the recommended location is the Windows desktop. 

3. The installation is complete and the application is ready to run. 
 
 

Description 
 
The Data Assistant application is a tool which facilitates the conversion of data 
from a textual-based delimited form such as CSV (Comma Separated Values) to 
another form such as HTML, XML or SQL. 
 
Anyone wishing to convert data from one compatible text form to another may 
find a use for this application.  This may be for the purposes of data migration, 
data formatting and data import / export. 
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Starting the application 
 

1. To start the application, double click on the DataAssistant.exe file which 
was extracted from the zip archive in the above section (Installation) 

 
 

2. The application will start. 
 
 

Finding your way around 
 

 
Fig 1.1 :  Main Application Window 

Legend: 
 

1. File Menu – This contains the functions for importing and exporting data 
to the main workspace (5) 

 
2. Edit Menu – The edit menu contains the find and replace functionality as 

well as the functions to select and deselect all items in the workspace. 
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3. Tools Menu – This menu contains tools which you can use to manipulate 
data.  Refer to section ??? for a detailed summary of each tool. 

 
4. Help Menu – The help menu contains information about the program. 

 
5. Workspace – The workspace area is where the data is viewed.  The 

workspace allows you to manipulate the data, and to sort the data. 
 

Importing a file 
 
To begin working with the application, you must first import a file.  File that can 
be imported are: 
 

• Comma Separated Values File (CSV) – These files contain plain text.  
Values are delimited by a comma, and rows are delimited by a linefeed 
(new line) 

 
• Tab Separated File (TAB) – These files contain plain text. Values are 

delimited by a TAB, and rows are delimited by a linefeed (new line). 
 

• User Specified File – Any plain text file that has values delimited by any 
character, and rows delimited by a linefeed (new line). 

 
To import a file: 
 

1. Click the File -> Open menu or press Ctrl + O 

 
 

Fig 1.2 : File menu 
 

2. The “Open File” dialogue will show. 
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Fig 1.3 : Open file dialog 
 

3. Select the file to import 
4. Click the “Open” button. 
5. Choose the delimiter which separates the values in the file, or choose 

“other” and supply your own. Comma is selected by default. 
 

 
 

Fig 1.4: Import dialog 
6. Click OK 
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Once these steps are complete, a validation will be performed on the file.  If 
there are validation errors with the file, the validation dialog will appear. 
 
 

Validation 
 
Validation checks that the file you are importing contains data which is 
consistent.  Validation will alert you if: 
 

• There are cells within your data which are empty, when other cells within 
that data contain information. 

• There are empty rows found within your data. 
 
To complete validation: 
 

1. The Validation window will appear and provide you with an informative 
message about the problems with your data. 

 

 
 

Fig 1.5 : Validation window 
 

2. Select an appropriate action by clicking one of the radio buttons. 
3. Click OK. 

 
If further validation errors are discovered, you may need to repeat this process. 
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Navigating the workspace 
 
Once you have imported your file and any validation has completed, the data file 
will be loaded into the workspace. 
 
Selecting Items 
In order to use the various tools available throughout the tools menu (described 
later), you may need to select specific parts of the data that you wish to perform 
an operation on.  Selecting data is achieved in one of the following ways: 
 
Selecting Cells 
To select a cell, simply click it with the left mouse button 
 
Selecting Rows 
To select a row, click the row header (to the left of the row) 
 
Selecting a range 
To select a range of data, left click on a cell and drag the mouse so that the 
desired cells become highlighted. 
 
Selecting All 
To select all cells, choose the Edit -> Select all menu item, or press Ctrl + A.  
 
Selecting None 
To deselect (select none) all cells, choose the Edit -> Select None menu item. 
 
Editing Cells 
 
To edit a cell, simply select it (refer to “Selecting Cells” above).  The cell will 
become highlighted and the text can now be edited.  Once editing is complete, 
hit the Enter or TAB key to commit your changes. 
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Fig 1.6 : Editing a cell 
 
Editing Column Headings 
 
To edit a column heading, right click on the column heading.  A popup menu will 
appear with a text box.  Enter the desired new heading into the text box and hit 
the Enter or TAB key to commit your changes. 
 

 
 

Fig 1.7 :  Editing headings 
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Sorting 
The contents of the workspace can be sorted.  Click the column heading 
corresponding to the column you wish to sort.  The workspace will sort in 
ascending order according to that column.  To sort decending, click the same 
column again. 
 

 
 

Fig 1.8 :  Sorting a column 
 
 
Resizing Columns and Rows 
Columns and rows can be resized for ease of viewing.  Please note that column 
and row resizing will have no effect on the exported data.  To resize a column or 
row, click on the dividing line between, and drag to the desired width. 
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Find and Replace 
 
Find 
The find feature allows you to locate specific text within your data.  To find text: 
 

1. Click the Edit -> Find menu or press Ctrl + F 
2. The find dialog will appear 

 

 
 

Fig 1.9 : Find dialog 
 

Legend: 
 

a) Text Box – This is where the string to find is specified. 
 
b) Match Case – Selecting this option will only show results which match 

the case you specified.  That is, the combination of upper case and 
lowercase letters. 

 
c) Match Entire Field – Selecting this will only produce results where the 

specified text matches the text of an entire cell in your data.  Un-
checking will find the specified text in any part of a cell. 

 
 

3. Enter the search term in the text box. 
4. Click the checkbox “Match case” if you wish to mach the casing of your 

criteria. 
5. Uncheck the “Match Entire Field” option if you wish to search for your text 

in part of a cell. 
6. Click Find. 
7. If any results are found, the cell will become highlighted. 
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8. Repeat steps 6-7 to find additional occurrences. 
 
Replace 
The Replace feature allows you to locate specific text within your data ad to 
replace it with other text.  To replace text: 
 

1. Click the Edit -> Replace menu or press Ctrl + R 
2. The Replace dialog will appear 

 

 
 

Fig 1.10 :  Replace dialog 
 

Legend: 
 

a) Find Text Box – This is where the string to find is specified. 
 
b) Match Case – Selecting this option will only show results which match 

the case you specified.  That is, the combination of upper case and 
lowercase letters. 

 
c) Match Entire Field – Selecting this will only produce results where the 

specified text matches the text of an entire cell in your data.  Un-
checking will find the specified text in any part of a cell. 

 
d) Replace with – The text to replace the found text with 

 
e) Replace button – Replaces the current occurrence. 

 
f) Replace All button – Replaces all occurrences of the specified text. 
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3. Enter the text to search for into the find text box. 
4. Enter the text to replace with into the Replace text box.  
5. Click “Find” to find an occurence 
6. Click “Replace” to replace the occurence. 
7. Alternatively, click “Replace All” to replace all occurences. 

 

Using Tools 
 
Tools Overview 
The Data Assistant tools are a handy way to manipulate large volumes of your 
data in preparation for export.  A summary of each tool is presented below. 
 
Escaper 
The escaper tool allows you to escape characters within the data with other 
characters.  This is frequently required for sql statements and alike.  To escape 
data: 
 

1. Select the data you wish to escape (refer to Selecting Items above)  
2. Click the Tools -> Escaper menu item 
3. The Escape Characters dialog will appear 

 

 
 

Fig 1.11 : Escape Characters dialog 
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Legend: 
 

a) Character to escape – This is the character within the data which 
needs to be escaped.  Printable characters can be entered directly into 
the text box via the keyboard. 

 
b) Hex Value – To escape non-printable characters, you can enter the hex 

value of the character in this text box. 
 

c) Escape Method – A range of escape methods are available.  Choose 
the most appropriate for your purposes 

 
d) Preview – The preview shows how the escape will look once applied to 

the data. 
 
 

4. Enter the character to escape, or type its hex value. 
5. Choose the escape method desired. 
6. Click “Escape All” 

 
URL Encoder 
The URL Encoder will prepare the data for use in URLs.  This replaces certain 
characters with encoded variants. 
 

1. Select the data you wish to URL encode (refer to Selecting Items above)  
2. Click the Tools -> URL Encoder menu item 
3. The selection will be encoded. 

 
 
Capitaliser 
The capitaliser allows you to change the case of text within your data.Text can 
be changes to UPPERCASE, lowercase and Proper Case.  To change the case of 
text: 
 

1. Select the data you wish to capitalise (refer to Selecting Items above)  
2. Click the Tools -> Capitaliser menu item 
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Fig 1.12 : Capitaliser dialog 
 

Legend: 
 

a) UPPERCASE  - Changes the text to UPPERCASE 
 
b) lowercase – Changes the text to lowercase 

 
c) Proper Case – Changes the text to Proper Case 

 
3. Select the desired casing 
4. Press OK to apply the changes to your selection. 

 

Exporting Data 
 
Export as text (delimited) 
This function allows you to export as a text-based delimited format such as CSV.  
To export as text: 
 

1. Click the File -> Export As -> text (delimited) menu item 
2. The Import / Export dialog will appear. 
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Fig 1.13 : Import/ export dialog 
 

3. Choose the delimiter you wish to use and click OK. 
4. Choose a valid filename and file extension and click “Save” 
5. The file will be saved and launched if possible. 

 
Export as sql 
This function allows you to export the data as SQL statements for import to a 
database. To export as SQL: 

1. Click the File -> Export As -> SQL menu item 
2. The Export as SQL dialog will appear: 

 

 
 

Fig 1.14 : Export as SQL dialog 
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3. Select whether you would like CREATE TABLE and/or INSERT statements 
generated. 

4. Enter a name for the table.  The name must no include spaces. 
5. Click Next 
6. The SQL Data Types dialog will appear: 

 

 
 

1.15 : SQL Datatypes dialog 
 

7. Choose the desired data types for each field of the table. The system has 
predicted the most appropriate datatypes for you. 

8. Enter a size for the field. The system has predicted the most apropriate 
sizes for you. 

9. You may rename the fields if required. 
10. Click Export. 
11. Enter a filename. 
12. Click Save. 
13. The file will be saved and will open if possible. 
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Export as html 
This function allows you to export as a html file where the data is presented in a 
html table.  To export as html: 
 

1. Click the File -> Export As -> html menu item 
2. The export as HTML window will appear: 

 

 
 

Fig 1.16 : Export as html dialog 
 

Legend: 
 

a) Table settings – This allows you to specify the border size and 
cellpadding for the table 

 
b) Heading settings – This allows you to specify the text colour, 

background colour and text style for the headings of the table 
 

c) Table Cell settings – This allows you to specify the text colour, 
background colour and text style for the cells of the table. 
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d) Edit Css button – This allows you to edit the raw CSS for the html 
document. 

 
e) Preview area  - This show you how the exported html document will 

look. 
 

3. Choose the desired formatting setting using each of the controles listed 
above. 

4. When you are satisfied with the appearance of the table, click Export. 
5. Enter a filename. 
6. Click Save. 
7. The file will be saved and will open if possible. 

 
Export as xml 
This function allows you to export as an xml file.  To export as xml: 
 

1. Click the File -> Export As -> xml menu item 
2. The export as XML window will appear: 
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Fig 1.17 : Export as xml dialog 
 

3. Enter the desired table name and attributes 
4. Enter the desired row name and attributes 
5. Enter the desired column names and attributes 
6. Click Export. 
7. Enter a filename. 
8. Click Save. 
9. The file will be saved and will open if possible. 
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