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01) Overview 
 

HOTSys  software developed considering day-to-day problems faced  by  small   

Hotel businesses due to non-use of technology, the software is designed to  

maintain  all  business  aspects of such hotels;  USP  of  HOTSys  is  easy  to use 

interface,  like   single   dashboard to get information of any room and click-to-

Checkout with finalization  of  bills, these simple to use features  enable  any 

user a quick and smooth operation even  on rush hours. 

 
02) Installation 

 
HOTSys comes with easy to use installation package, requires the user to run 

SETUP.EXE file from the distribution media and follow on screen instructions to 

complete the installation. There are  some pre-requisite installations required to 

run HOTSys (see system requirements). HOTSys can be installed in networked 

environment by sharing data file on network shared folder. 

 
•  Minimum requirements to install and run HOTSys 

• P-4 compatible system with 256MB RAM (recommended 512MB RAM) 

or above 

• 500MB HDD free space 

•  Windows 98 or above 

• Microsoft Data Access Component 2.6 or above (can be found on 

distribution media) 

 

03) Initiating HOTSys 
 

• After successful installation of HOTSys, run the software from desktop icon 

named HOTSys, First run asks you to register your software, click on “Yes” to 

go for Registration or click on “No” to continue with Demo. See blow screen 1.1, 

1.2, 1.3. 

 
Screen 1.1 

 

 

 

 

• If you click “Yes”, get a screen for registration, fill the registration details 

like Registration Name and Client ID (provided by us after purchas ing a 

license), click Copy Registration Details to copy these details and send 

the same to our email id registration@soft-tech.co.in. We would be then 

provide you registration keys by replying your email, fill those keys in 

four blank boxes and click “OK” to register the software. See Screen 1.2. 

 
Screen 1.2 

mailto:registration@soft-tech.co.in
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• After successful registration restart the software, to get login screen see 

Screen 1.3. 
Screen 1.3 

 

 
 

• Default Company Name is Demo Company, User ID is HOTSys and 

Password is HOTSys, these details can be changed once logged in to the 

system. 

• On  first run the system  asks  to select  file  (data source) name, select 

HOTSysData.mdb file, which  is located by default in your installation 

folder (normally C:\Program Files\HOTSys). See Screen 2.1 and 2.2. 

 

Screen 2.1 
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• Click on “Yes” if you like to select Data file or else click “No” to 
continue with default Data. See Screen 2.2 how to select Data. 

 
Screen 2.2 

 

 

 
• Select HOTSysData.mdb file and click on “Open”, you would get 

confirmation message “DSN Created successfully”. 
• HOTSys is n o w ready to go. 

• You may create new users or change user rights or password of existing 

users from House-Keeping->User Master menu option; default User ID 

and Password HOTSys is assigned with full administrative rights. 

• You may assign user rights from the same menu option, users can be 

restricted with option for add / modify / delete in all modules 

• Note: - User Rights abbreviations are as follows 

01  Add (Adding of new Records are allowed) 

02  Edit (Modifying of records are allowed) 

03  Delete (Delete of Records are allowed) 

SU Supervisor (All administrative rights) 

OP Operator Special abbreviation to restrict the user from delete bills (Bill 

Correction Option) 

• You may edit default company details from menu File->Company Master 

and give all details about the name and address of Hotel. 

 

 



Page 5 of 12 

04) Prepare Master Data 
 

To start working in live environment, master data has to be prepared first 

time, like “Menu Room Group”, “Room No”, ”Account Head”, “Debtors 

Name” has to be defined. 

• Manage all Group of Rooms from File->Room Group Master menu option. 

• Manage all Menu Rooms from File->Room Master menu option. 

• Manage all Customers and Account heads including Cash / Different 

types of credit cards from File->Customer Master Menu option. 
 
 
 
 
05) Check-In 

Screen 3 

 

 

 

• You may enter Guest Check-In details from File->Check-In Entries menu option. 

• To enter new Check-In Click Add and fill in Credit To, Reg. No, Arrival Date, 

Arrival Time, Persons, Room No, Discount %, Extra Bed, Guest Name, 

Guest Address, City, Image scan and click update button to save the entry. 

You may add subsequent Check-In by clicking Add button. See 

Screen 3. 
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06) Room Information Status 
Screen 4 

 

• You may open Room Information Windows from Window->Information Window 

menu option. 

• While entering Check-In, you will notice room status Information on the 

screen shows Room Numbers of occupied rooms. At any given time you can 

check pending room or check out the room by clicking on the room number. 

See Screen 4. 
•  

07) Laundry Item 
Screen 5 
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• You may enter Laundry Entry from File->Laundry Entries menu option. 

• To entry new Laundry Entry Add and fill in Slip Number, Date, Time, Room No, Tax 

(%), Account, Item Name, Item Quantity details and click update button to save 

the entry. You can add more Laundry Entry by clicking Add button. 

• You may also modify Item and Quantity details within the grid and save the 

changes with update button. See Screen 5. 

 

 

08) Room Transaction   
Screen6 

 

 

• You may enter Room Transaction Entry from File->Transection Entries menu 

option. 

• To enter new Room Transaction Click Add and fill in Slip Number, 

Date, Time, Room No, Account and Amount, click update button to 

save the entry. Add more Transection by clicking Add button again. 
See Screen 6. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

09) Check-Out   



Page 8 of 12 

 
Screen 7 

 

• To Check-Out the room click on the room number on Information status, click yes 

for check-out, Check-Out window would auto fill current Date, Time, Advance 

Amount and other relevant data, if customer pays amount by Credit Card or 

credit to customer account select Credit to and change as payment mode and 

then click Preview button to update and preview room data, click update button 

check-out the room, after check-out click print bill to get the bill printed. See 

Screen 7. 

 

10) Undo Check-Out  
Screen 8 
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• For Undo Check-Out go to House Keeping->Undo Check-Out menu option. 

• When open Undo Check-Out form enter register number and click on update 

button to Undo Check-Out. See Screen 8. 

 

11) Modify Bill   

 
Screen 9 

 

 

• To modify bill details go to House Keeping->Modify Bill menu option. 

• Key-in Register Number of the bill to modify, you may change mode of payment 

by changing Credit To values, option is provided to print only selected values in 

the invoice for various client requirements.. See Screen 9. 

 

12) Generating Reports 
 

• Various reports may be generated by key-in criteria for reports in relevant boxes 

like Starting and Ending Date, Time select appropriate button to generate 

report on screen (Drill-Down), Print Preview, Print to Printer or Email 

Report 

•  Every report may be sent through Email by keying in email parameters, 

Microsoft Outlook or Outlook Express should be configured to use this 

feature. 

• You can set or change printer configuration from Printer Setup Button of 

relevant report. 

• You may change sorting order of any report in Drill-Down report by 

1) Clicking in any row of column to sort and then 2) Clicking on the 

heading of the same column) 

• Once you close drill-down report, you will be presented with an option to 

Print Previewed Report Check-Box, if you select this check box the report 

generated will retain its Sorting Order and Condition for other options like 

Print Preview, Print or Email. 

• You may drill-down up to the Transection Entry by double-clicking or pressing 

Enter key on relevant data row in all Drill-Down Report screen. 

 

 

 

 

 

 

 

 

13) User Rights Management 
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•  Administrators may create, delete or modify users from House-Keeping- 

>User Master menu option 

•  Users may be assigned with Module Rights and Option Rights 

• Module Rights: 

• These rights defined users’ role for Menu Options like you can 

control whether user can open Menu Options available (like File- 

>Transaction) 

•  Every module is numbered from its location like File->Company 

Master is numbered as 00, Room Group Master as 01 
…. 

• Likewise House Keeping->Change Color as 18 number (Remember 

to count line separators) 

•  For example you want to assign  any user “Check-In Entries”, 

“Laundry Entries” and “Transection Entries Option you can give  

Module  Rights as 08 09 10 (See Module  Listing section for 

explanation on Page No. 11). 

 
• Option Rights 

• These rights defined users’ role for tasks like Add / Modify / Delete 

control. 

•  Every option is numbered from its location like Add is numbered as 

01, Modify as 02. 

•  For example you want to assign any user Add and Delete option, 

you can give Option Rights as 01 03. (By default 06 (Close Option) 

is available to all users). 

 

14) General Information for All Data Entry Modules 
 

•  User may Add new entries in any module either by clicking Add button 

(1st from lower left corner) or by pressing Ctrl+A key combination. 

•  User may Edit current record in any module either by clicking Modify button 

(2nd from lower left), or by pressing Ctrl+M key combination. 

•  User may delete current record either by clicking Delete button (3rd from 

lower left), or by pressing Ctrl+D key combination. 

•  User may search record by clicking Search button (5th from lower left) 

•  User may move to next or previous record either by clicking Arrow Buttons 

on either side of bottom screen or by pressing PgUp or PgDn keys. 

•  User may move to Last or First record either by pressing Ctrl+PgUp or 

Ctrl+PgDn key combination or by pressing Home or End keys. 

•  User may save record either by clicking on Update button or by pressing 

Ctrl+S key combination when in Add or Edit Mode. 

 
Note: Availability of option may depend on user rights and database mode. 

Like Add / Modify / Delete / Search / Close / Next / Previous buttons will 

be disabled when record is being modified or added. 

 

15) Terms Used in this Manual 

 
• Menu option File->Exit means select Exit option from File menu 

•  Clicking Button means click on available rectangular box. 

•  Toolbar means Icon representation of menu options below the Main-Menu in 

main form 

• Module Rights means option particular user is entitled to use. 

• Option Rights means particular task like Addition, Modification, Deletion of 

Entry, user entitled to use. 
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16) Module List 
 

Module  No. Module  Name 
File Menu 
00 Company Master 
01 Room Group Master 
02 Room Master 
03 Account Head 
04 Debtors Master 
05 Guest Details 

06 

 
 

------------------------ 
07 Advance Booking Entries 
08 Check-In Entries 
09 Laundry Entries 

10 Transection Entries 

11 Check-Out Entries 

12 Check-In Entries (Booking) 

13 Receipt Entries 

14 Receipt Entries (Multi Bill) 

15 ------------------------ 
16 Exit 
17 Logout 
House Keeping  Menu 
18 Change  Color 
19 User Master 
20 System Parameters 
21 Document Designer 
22 Undo Check-Out 

23 Collect TelCap Data 

 24 Collect RMSys Data 

25 Directory Inquiry 

26 Tariff Change 

27 Modify Bill 

28 Export to AMISys 

29 Export to Tally 

Report Menu 
30 Daily Cash 
31 Daily Income 
32 Daily Transaction 
33 Daily Check-In Report 
34 Daily Check-Out Report 

35 Room wise Bills 

36 Debtor wise Bills 

37 Guest Register 

38 Daily Receipt  

39 ------------------------ 
40 Room wise income Summary 
41 Debtor wise Bill Summary 
42 Date wise Income Summary 
43 Room Status 
44 Daily Flash Report 
45 Advance Booking Report 
46 Daily Cash Summary 
47 FORM III (Tax Register) 

48 Outstanding Bills 
Optional Report 

49 Reg. Transections 
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50 Day wise Summary 

51 Day wise Chart 

52 Print Old Modified Bill 

53 Daily Cash Report (With Modify) 

54 Daily Print Report 

55 Invoice Print Summary 

56 Daily Status 

57 Laundry Report 

58 ------------------------ 

59 Discount Report 

 
 
 

17) Contact Information 
 

Soft-Tech Computers 
205, 216/12B, 2nd  Floor, Sai Baba Complex, 

City Police Station Road, 

Gandhidham – (Kutch) 370 201 

Gujarat – India 

Ph. +91 2836 224777 

Website: http://www.soft-tech.co.in 

Email: info@soft-tech.co.in 
 

 
Disclaimer: Other product or business names mentioned in this document are 

trademarks of their respective owners. 
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